Email Encryption Maintenance - ZIX
Scheduled for Dec 15, 02:00 - 04:00 UTC
Update
Please be advised that the date for this maintenance has been changed. The impact however remains unchanged. Here is the updated schedule:

Updated Schedule
• Start: December 15, 2018, at 02:00 UTC
• End: December 15, 2018, at 04:00 UTC
Posted 8 days ago. Dec 06, 2018 - 19:30 UTC
Scheduled
Our encryption provider ZIX will be performing maintenance on December 8, 2018, at 02:00 UTC, for the duration of 2 hours. During this service maintenance your encrypted email flow will be queued and delivered once the maintenance has been completed. All other aspects of our service will continue to function as normal.
Posted 11 days ago. Dec 03, 2018 - 14:36 UTC
This scheduled maintenance affects: Email Security.cloud (Europe, Middle East & Africa, Americas, Japan, Asia Pacific).